PKGBUILDs/qt5-tools/mingw-w64/qt5-fix-linguist-cmake-macro.patch
Martchus eb22ef4d46 Use native OpenGL in default variant
- Also fix misc issues with mingw-w64-qt5-base-static
- Also provide static libs for mingw-w64-qt5-declarative
  and mingw-w64-qt5-tools (other modules are still
  on TODO list)
- First approach to allow usage of static version via CMake
- Use native OpenGL by default because this version seems
  less buggy and ANGLE is hard to maintain; this is also the
  default choice in MSYS2-MINGW-packages and MXE
2016-08-14 20:44:49 +02:00

26 lines
1.0 KiB
Diff

--- src/linguist/Qt5LinguistToolsMacros.cmake.orig 2016-06-19 17:29:46.000000000 +0200
+++ src/linguist/Qt5LinguistToolsMacros.cmake 2016-07-23 00:39:31.718139700 +0200
@@ -71,8 +71,10 @@
file(WRITE ${_ts_lst_file} "${_lst_file_srcs}")
endif()
+
+ get_target_property(LUPDATE_LOC ${Qt5_LUPDATE_EXECUTABLE} IMPORTED_LOCATION)
add_custom_command(OUTPUT ${_ts_file}
- COMMAND ${Qt5_LUPDATE_EXECUTABLE}
+ COMMAND ${LUPDATE_LOC}
ARGS ${_lupdate_options} "@${_ts_lst_file}" -ts ${_ts_file}
DEPENDS ${_my_sources} ${_ts_lst_file} VERBATIM)
endforeach()
@@ -93,8 +95,9 @@
set(qm "${CMAKE_CURRENT_BINARY_DIR}/${qm}.qm")
endif()
+ get_target_property(LRELEASE_LOC ${Qt5_LRELEASE_EXECUTABLE} IMPORTED_LOCATION)
add_custom_command(OUTPUT ${qm}
- COMMAND ${Qt5_LRELEASE_EXECUTABLE}
+ COMMAND ${LRELEASE_LOC}
ARGS ${_abs_FILE} -qm ${qm}
DEPENDS ${_abs_FILE} VERBATIM
)