PKGBUILDs/qt5-base/mingw-w64-angle/qt5-dont-add-resource-files-to-qmake-libs.patch
Martchus eb22ef4d46 Use native OpenGL in default variant
- Also fix misc issues with mingw-w64-qt5-base-static
- Also provide static libs for mingw-w64-qt5-declarative
  and mingw-w64-qt5-tools (other modules are still
  on TODO list)
- First approach to allow usage of static version via CMake
- Use native OpenGL by default because this version seems
  less buggy and ANGLE is hard to maintain; this is also the
  default choice in MSYS2-MINGW-packages and MXE
2016-08-14 20:44:49 +02:00

12 lines
468 B
Diff

--- qtbase-opensource-src-5.2.0/qmake/generators/win32/mingw_make.cpp.orig 2014-01-04 21:18:07.413328813 +0100
+++ qtbase-opensource-src-5.2.0/qmake/generators/win32/mingw_make.cpp 2014-01-04 21:18:55.740126515 +0100
@@ -243,7 +243,7 @@
processVars();
- project->values("QMAKE_LIBS") += project->values("RES_FILE");
+ project->values("OBJECTS") += project->values("RES_FILE");
if (project->isActiveConfig("dll")) {
QString destDir = "";