PKGBUILDs/qt5-base/mingw-w64-static/0013-Fix-linking-against-shared-static-MariaDB.patch
Martchus c9819b9c7c Update mingw-w64-qt5-* to 5.8.0
* Adapt hacks to new config system
* Use distinct mkspec mingw-w64-g++ rather than
  patching the existing win32-g++
* Testing QML and ANGLE is on TODO list
  because it hasn't been tested since quite a time
2017-02-09 16:10:06 +01:00

27 lines
1.1 KiB
Diff

From acbc69f1a6d40c8a4106e4b931650b6921a40503 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 18 Sep 2016 18:56:55 +0200
Subject: [PATCH 13/30] Fix linking against shared/static MariaDB
---
src/sql/configure.json | 3 +++
1 file changed, 3 insertions(+)
diff --git a/src/sql/configure.json b/src/sql/configure.json
index 96c82e84f9..7219926cf5 100644
--- a/src/sql/configure.json
+++ b/src/sql/configure.json
@@ -58,6 +58,9 @@
"label": "MySQL",
"test": "unix/mysql",
"sources": [
+ { "libs": "-lmariadbclient -lssl -lcrypto -lws2_32 -lpthread -lz -lm", "condition": "config.win32 && !features.shared" },
+ { "libs": "-Wl,-Bdynamic -lmariadb -Wl,-Bstatic", "condition": "config.win32 && !features.shared" },
+ { "libs": "-lmariadb", "condition": "config.win32 && features.shared" },
{ "type": "mysqlConfig", "query": "--libs_r" },
{ "type": "mysqlConfig", "query": "--libs" },
{ "libs": "-lmysqlclient_r", "condition": "!config.win32" },
--
2.11.1