PKGBUILDs/qt5-base/mingw-w64-angle/0014-Fix-linking-against-shared-static-PostgreSQL.patch
Martchus c9819b9c7c Update mingw-w64-qt5-* to 5.8.0
* Adapt hacks to new config system
* Use distinct mkspec mingw-w64-g++ rather than
  patching the existing win32-g++
* Testing QML and ANGLE is on TODO list
  because it hasn't been tested since quite a time
2017-02-09 16:10:06 +01:00

30 lines
1.3 KiB
Diff

From 0712fd493611c503092fe616b4bd1c75e1d5d5ee Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 18 Sep 2016 18:58:25 +0200
Subject: [PATCH 14/30] Fix linking against shared/static PostgreSQL
---
src/sql/configure.json | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/src/sql/configure.json b/src/sql/configure.json
index 7219926cf5..713254b8cf 100644
--- a/src/sql/configure.json
+++ b/src/sql/configure.json
@@ -72,9 +72,10 @@
"label": "PostgreSQL",
"test": "unix/psql",
"sources": [
- { "type": "pkgConfig", "args": "libpq" },
{ "type": "psqlConfig" },
- { "type": "psqlEnv", "libs": "-llibpq -lws2_32 -ladvapi32", "condition": "config.win32" },
+ { "type": "psqlEnv", "libs": "-lpq -lintl -lssl -lcrypto -lshell32 -lws2_32 -lsecur32", "condition": "config.win32 && !features.shared" },
+ { "type": "psqlEnv", "libs": "-Wl,-Bdynamic -lpq -Wl,-Bstatic", "condition": "config.win32 && !features.shared" },
+ { "type": "psqlEnv", "libs": "-lpq", "condition": "config.win32 && features.shared" },
{ "type": "psqlEnv", "libs": "-lpq", "condition": "!config.win32" }
]
},
--
2.11.1