PKGBUILDs/qt5-base/mingw-w64/0023-Use-correct-pkg-config-static-flag.patch
Martchus f98e3bef4b Adapt patches for mingw-w64 Qt 5 packages
* Update patch for static freetype2 in qt5 for brotli library renaming
* Update patches for Qt 5 SQL drivers to include crypt32
    * This library is required by OpenSSL's crypto library. Not sure
      why there were no linker errors before.
2024-01-09 17:32:31 +01:00

27 lines
751 B
Diff

From 4e95aba534172824d9756ec22bfe903d29d98e54 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 18 Sep 2016 18:50:21 +0200
Subject: [PATCH 23/32] Use correct pkg-config --static flag
---
configure.pri | 3 +++
1 file changed, 3 insertions(+)
diff --git a/configure.pri b/configure.pri
index 85acb3757a..0a4db10dfc 100644
--- a/configure.pri
+++ b/configure.pri
@@ -360,6 +360,9 @@ defineTest(qtConfTest_detectPkgConfig) {
qtLog("Found pkg-config from path: $$pkgConfig")
}
}
+ !isEmpty(pkgConfig):qtConfig(static) {
+ pkgConfig = "$$pkgConfig --static"
+ }
$$qtConfEvaluate("features.cross_compile") {
# cross compiling, check that pkg-config is set up sanely
--
2.43.0