PKGBUILDs/qt5-base/mingw-w64/0017-Use-system-zlib-for-build-tools.patch
Martchus f98e3bef4b Adapt patches for mingw-w64 Qt 5 packages
* Update patch for static freetype2 in qt5 for brotli library renaming
* Update patches for Qt 5 SQL drivers to include crypt32
    * This library is required by OpenSSL's crypto library. Not sure
      why there were no linker errors before.
2024-01-09 17:32:31 +01:00

28 lines
770 B
Diff

From 83459578b49cefb55f3977182b2f2a8dff1eff32 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 18 Sep 2016 18:04:42 +0200
Subject: [PATCH 17/32] Use system zlib for build tools
---
src/tools/bootstrap/bootstrap.pro | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/src/tools/bootstrap/bootstrap.pro b/src/tools/bootstrap/bootstrap.pro
index 24862a07db..698e6cfb95 100644
--- a/src/tools/bootstrap/bootstrap.pro
+++ b/src/tools/bootstrap/bootstrap.pro
@@ -158,7 +158,9 @@ macx {
../../corelib/io/qstandardpaths_win.cpp
}
-!qtConfig(system-zlib)|cross_compile {
+cross_compile {
+ LIBS += -lz
+} else:!qtConfig(system-zlib) {
include(../../3rdparty/zlib.pri)
} else {
CONFIG += no_core_dep
--
2.43.0