PKGBUILDs/qt5-base/mingw-w64/0005-Don-t-add-resource-files-to-LIBS-parameter.patch
Martchus f98e3bef4b Adapt patches for mingw-w64 Qt 5 packages
* Update patch for static freetype2 in qt5 for brotli library renaming
* Update patches for Qt 5 SQL drivers to include crypt32
    * This library is required by OpenSSL's crypto library. Not sure
      why there were no linker errors before.
2024-01-09 17:32:31 +01:00

29 lines
951 B
Diff

From 1509d40b75406e82868a8150080ce6137095115a Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 18 Sep 2016 13:58:28 +0200
Subject: [PATCH 05/32] Don't add resource files to LIBS parameter
Solves an issue where the generated pkg-config
files contained invalid Libs.private references
like .obj/debug/Qt5Cored_resource_res.o
---
qmake/generators/win32/mingw_make.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/qmake/generators/win32/mingw_make.cpp b/qmake/generators/win32/mingw_make.cpp
index ee9a41838b..8d1dcae85b 100644
--- a/qmake/generators/win32/mingw_make.cpp
+++ b/qmake/generators/win32/mingw_make.cpp
@@ -147,7 +147,7 @@ void MingwMakefileGenerator::init()
processVars();
- project->values("LIBS") += project->values("RES_FILE");
+ project->values("OBJECTS") += project->values("RES_FILE");
if (project->isActiveConfig("dll")) {
QString destDir = "";
--
2.43.0