PKGBUILDs/qt5-base/mingw-w64-static/qt5-fix-static-psql-mysql.patch
Martchus eb22ef4d46 Use native OpenGL in default variant
- Also fix misc issues with mingw-w64-qt5-base-static
- Also provide static libs for mingw-w64-qt5-declarative
  and mingw-w64-qt5-tools (other modules are still
  on TODO list)
- First approach to allow usage of static version via CMake
- Use native OpenGL by default because this version seems
  less buggy and ANGLE is hard to maintain; this is also the
  default choice in MSYS2-MINGW-packages and MXE
2016-08-14 20:44:49 +02:00

16 lines
622 B
Diff

--- config.tests/unix/psql/psql.pro.orig 2015-02-16 21:56:55.000000000 -0700
+++ config.tests/unix/psql/psql.pro 2015-03-09 21:45:44.746755052 -0600
@@ -1,3 +1,3 @@
SOURCES = psql.cpp
CONFIG -= qt dylib
-LIBS *= -lpq
+LIBS *= -lpq -lintl -liconv -lssl -lcrypto -lwldap32 -lshfolder -lwsock32 -lws2_32 -lsecur32 -lgdi32
--- config.tests/unix/mysql/mysql.pro.orig 2015-02-16 21:56:55.000000000 -0700
+++ config.tests/unix/mysql/mysql.pro 2015-03-09 21:38:59.930405876 -0600
@@ -1,3 +1,3 @@
SOURCES = mysql.cpp
CONFIG -= qt dylib
-LIBS += -lmysqlclient
+LIBS += -lmariadbclient -lws2_32 -lpthread -lz -lm -lssl -lcrypto