PKGBUILDs/qt5-base/mingw-w64-static/qt5-fix-linking-against-static-pcre.patch
Martchus eb22ef4d46 Use native OpenGL in default variant
- Also fix misc issues with mingw-w64-qt5-base-static
- Also provide static libs for mingw-w64-qt5-declarative
  and mingw-w64-qt5-tools (other modules are still
  on TODO list)
- First approach to allow usage of static version via CMake
- Use native OpenGL by default because this version seems
  less buggy and ANGLE is hard to maintain; this is also the
  default choice in MSYS2-MINGW-packages and MXE
2016-08-14 20:44:49 +02:00

14 lines
396 B
Diff

--- qtbase-opensource-src-5.1.0/src/corelib/tools/qregularexpression.cpp.orig 2013-07-11 08:23:02.687691337 +0200
+++ qtbase-opensource-src-5.1.0/src/corelib/tools/qregularexpression.cpp 2013-07-11 08:23:27.231900674 +0200
@@ -47,6 +47,10 @@
#include <QtCore/qatomic.h>
#include <QtCore/qdatastream.h>
+#ifdef QT_STATIC
+#define PCRE_STATIC
+#endif
+
#include <pcre.h>
QT_BEGIN_NAMESPACE