PKGBUILDs/qt5-base/mingw-w64-static/qt5-dont-build-host-libs-static.patch
Martchus eb22ef4d46 Use native OpenGL in default variant
- Also fix misc issues with mingw-w64-qt5-base-static
- Also provide static libs for mingw-w64-qt5-declarative
  and mingw-w64-qt5-tools (other modules are still
  on TODO list)
- First approach to allow usage of static version via CMake
- Use native OpenGL by default because this version seems
  less buggy and ANGLE is hard to maintain; this is also the
  default choice in MSYS2-MINGW-packages and MXE
2016-08-14 20:44:49 +02:00

20 lines
732 B
Diff

--- mkspecs/features/qt_module.prf.orig 2013-07-31 20:37:56.789883201 +0200
+++ mkspecs/features/qt_module.prf 2013-07-31 20:38:06.013034478 +0200
@@ -25,7 +25,7 @@
# Compile as shared/DLL or static according to the option given to configure
# unless overridden. Host builds are always static
-host_build|staticlib: CONFIG += static
+staticlib: CONFIG += static
host_build {
QT -= gui # no host module will ever use gui
--- src/tools/bootstrap-dbus/bootstrap-dbus.pro.orig 2013-12-08 11:09:47.000000000 -0600
+++ src/tools/bootstrap-dbus/bootstrap-dbus.pro 2014-01-05 23:06:13.575543400 -0600
@@ -30,4 +30,4 @@
../../dbus/qdbusunixfiledescriptor.cpp
lib.CONFIG = dummy_install
-INSTALLS = lib
+INSTALLS += lib