PKGBUILDs/qt5-base/mingw-w64-static/qt5-customize-extensions-for-static-build.patch
Martchus eb22ef4d46 Use native OpenGL in default variant
- Also fix misc issues with mingw-w64-qt5-base-static
- Also provide static libs for mingw-w64-qt5-declarative
  and mingw-w64-qt5-tools (other modules are still
  on TODO list)
- First approach to allow usage of static version via CMake
- Use native OpenGL by default because this version seems
  less buggy and ANGLE is hard to maintain; this is also the
  default choice in MSYS2-MINGW-packages and MXE
2016-08-14 20:44:49 +02:00

16 lines
528 B
Diff

--- mkspecs/features/spec_pre.prf.orig 2016-06-10 08:48:56.000000000 +0200
+++ mkspecs/features/spec_pre.prf 2016-08-09 16:42:35.000000000 +0200
@@ -14,9 +14,9 @@
QMAKE_EXT_H_MOC = .cpp
QMAKE_EXT_JS = .js
QMAKE_EXT_LEX = .l
-QMAKE_EXT_LIBTOOL = .la
-QMAKE_EXT_PKGCONFIG = .pc
-QMAKE_EXT_PRL = .prl
+QMAKE_EXT_LIBTOOL = -static.la
+QMAKE_EXT_PKGCONFIG = -static.pc
+QMAKE_EXT_PRL = -static.prl
QMAKE_EXT_UI = .ui
QMAKE_EXT_YACC = .y