PKGBUILDs/qt5-declarative/mingw-w64/0001-Build-QML-dev-tools-as...

28 lines
758 B
Diff

From 4924f5854a96eda470551762f90b64102de2a9cf Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:24:15 +0200
Subject: [PATCH 1/3] Build QML dev tools as shared library
---
src/qmldevtools/qmldevtools.pro | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/src/qmldevtools/qmldevtools.pro b/src/qmldevtools/qmldevtools.pro
index a21988b91..fc5c4d05d 100644
--- a/src/qmldevtools/qmldevtools.pro
+++ b/src/qmldevtools/qmldevtools.pro
@@ -2,6 +2,10 @@ option(host_build)
TARGET = QtQmlDevTools
QT = core-private
CONFIG += minimal_syncqt internal_module qmldevtools_build
+win32:!contains(CONFIG, static) {
+ CONFIG += shared
+ CONFIG -= static staticlib
+}
MODULE_INCNAME = QtQml
--
2.14.2