PKGBUILDs/qt5-declarative/mingw-w64/0001-Build-QML-dev-tools-as-shared-library.patch
Martchus defbb48223 Change work around for using static Qt 5 with CMake
* Make it possible to use shared and static Qt build (installed
  in the same prefix) at the same time in a project.
* This allows compiling shared and static libraries depending on
  Qt in one step.
* Static CMake modules are prefixed with 'Static', eg. 'StaticQt5Core'
  and provide importet targets as eg. 'Qt5::static::Core'.
2016-11-02 21:25:48 +01:00

26 lines
779 B
Diff

From 4fb746894af3a46afcc117aa48c20b0440e002b2 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:24:15 +0200
Subject: [PATCH 1/3] Build QML dev tools as shared library
---
src/qmldevtools/qmldevtools.pro | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/qmldevtools/qmldevtools.pro b/src/qmldevtools/qmldevtools.pro
index acd5c97..8b7b999 100644
--- a/src/qmldevtools/qmldevtools.pro
+++ b/src/qmldevtools/qmldevtools.pro
@@ -1,7 +1,7 @@
option(host_build)
TARGET = QtQmlDevTools
QT = core-private
-CONFIG += static internal_module qmldevtools_build
+CONFIG += internal_module qmldevtools_build
# Don't use pch because the auto-generated header refers to QtBootstrap,
# which doesn't exist
--
2.10.1