PKGBUILDs/qt5-declarative/mingw-w64/0002-Ensure-static-plugins-are-exported.patch
Martchus c9819b9c7c Update mingw-w64-qt5-* to 5.8.0
* Adapt hacks to new config system
* Use distinct mkspec mingw-w64-g++ rather than
  patching the existing win32-g++
* Testing QML and ANGLE is on TODO list
  because it hasn't been tested since quite a time
2017-02-09 16:10:06 +01:00

23 lines
789 B
Diff

From b480b775adc7224a83338356a9228bed5d538618 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 23 Oct 2016 01:18:13 +0200
Subject: [PATCH 2/3] Ensure static plugins are exported
---
src/qml/Qt5QmlConfigExtras.cmake.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/qml/Qt5QmlConfigExtras.cmake.in b/src/qml/Qt5QmlConfigExtras.cmake.in
index 9ddb9885c..9775d85e0 100644
--- a/src/qml/Qt5QmlConfigExtras.cmake.in
+++ b/src/qml/Qt5QmlConfigExtras.cmake.in
@@ -1,4 +1,4 @@
-file(GLOB _qt5qml_other_plugins "${CMAKE_CURRENT_LIST_DIR}/Qt5Qml_*Factory.cmake")
+file(GLOB _qt5qml_other_plugins "${CMAKE_CURRENT_LIST_DIR}/*Qt5Qml_*Factory.cmake")
foreach(_other_plugin ${_qt5qml_other_plugins})
include(${_other_plugin} OPTIONAL)
--
2.11.0