PKGBUILDs/qt5-webkit/mingw-w64/0001-Use-correct-ICU-libs.patch
Martchus c9819b9c7c Update mingw-w64-qt5-* to 5.8.0
* Adapt hacks to new config system
* Use distinct mkspec mingw-w64-g++ rather than
  patching the existing win32-g++
* Testing QML and ANGLE is on TODO list
  because it hasn't been tested since quite a time
2017-02-09 16:10:06 +01:00

28 lines
840 B
Diff

From 5d5d3ebbe9edcec899f4d11ce6709c533b446e25 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:53:59 +0200
Subject: [PATCH 1/9] Use correct ICU libs
The ICU libraries used for cross-compilation are named
exactly the same as their native Linux counterpart
---
Source/WTF/WTF.pri | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Source/WTF/WTF.pri b/Source/WTF/WTF.pri
index 69e4cd1f3..b553075c2 100644
--- a/Source/WTF/WTF.pri
+++ b/Source/WTF/WTF.pri
@@ -14,7 +14,7 @@ mac {
INCLUDEPATH = $${ROOT_WEBKIT_DIR}/Source/WTF/icu $$INCLUDEPATH
LIBS += -licucore
} else:!use?(wchar_unicode): {
- win32 {
+ win32:!mingw {
CONFIG(static, static|shared) {
CONFIG(debug, debug|release) {
LIBS += -lsicuind -lsicuucd -lsicudtd
--
2.11.0