PKGBUILDs/qt5/android-armv7a-eabi/0004-Use-pkg-config-to-find-libjpeg.patch
Martchus 8bcbcdde52 Revert android-*-qt5 packages to 5.13.1
Further versions broke the build system,
see 18443d861e.

With 5.15.1 it basically works again but deployment with androiddeployqt
does not produce runnable APKs. Qt now has gained support for invoking
androiddeployqt within CMake. Using their official support instead of my
own helper might have worked but it could not cope with the fact that I
had multiple targets in my CMake project and was therefore useless in my
case.

So let's ditch Qt 5 on Android  and give Qt 6 another chance at some
point.
2020-12-05 21:44:04 +01:00

25 lines
700 B
Diff

From 9cd435c730949e29104bbfa2bdd82ed2c662ca3d Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 7 Sep 2019 13:21:37 +0200
Subject: [PATCH 4/4] Use pkg-config to find libjpeg
---
src/gui/configure.json | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/gui/configure.json b/src/gui/configure.json
index 6280b4dfa2..206f83984a 100644
--- a/src/gui/configure.json
+++ b/src/gui/configure.json
@@ -373,6 +373,7 @@
},
"headers": "jpeglib.h",
"sources": [
+ { "type": "pkgConfig", "args": "libjpeg" },
{ "libs": "-llibjpeg", "condition": "config.msvc" },
"-ljpeg"
]
--
2.23.0