PKGBUILDs/qt5/android-aarch64/0003-Support-pkg-config-under-Android.patch
Martchus 8bcbcdde52 Revert android-*-qt5 packages to 5.13.1
Further versions broke the build system,
see 18443d861e.

With 5.15.1 it basically works again but deployment with androiddeployqt
does not produce runnable APKs. Qt now has gained support for invoking
androiddeployqt within CMake. Using their official support instead of my
own helper might have worked but it could not cope with the fact that I
had multiple targets in my CMake project and was therefore useless in my
case.

So let's ditch Qt 5 on Android  and give Qt 6 another chance at some
point.
2020-12-05 21:44:04 +01:00

25 lines
827 B
Diff

From a71a1223328539ee403884a24d1dbc5a685d40dd Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 7 Apr 2019 09:54:49 +0200
Subject: [PATCH 3/4] Support pkg-config under Android
from https://aur.archlinux.org/cgit/aur.git/commit/?h=android-aarch64-qt5&id=d901da324b2ceea2ac99b48137cb82b2bd920c77
---
mkspecs/android-clang/qmake.conf | 3 +++
1 file changed, 3 insertions(+)
diff --git a/mkspecs/android-clang/qmake.conf b/mkspecs/android-clang/qmake.conf
index 83d030793b..8f145a2bb7 100644
--- a/mkspecs/android-clang/qmake.conf
+++ b/mkspecs/android-clang/qmake.conf
@@ -53,3 +53,6 @@ else: \
QMAKE_CFLAGS_OPTIMIZE_SIZE = -Oz
include(../common/android-base-tail.conf)
+
+QMAKE_PKG_CONFIG = $$[QT_INSTALL_PREFIX]
+QMAKE_PKG_CONFIG = android-$$section(QMAKE_PKG_CONFIG, /, 3, 3)-pkg-config
--
2.23.0