PKGBUILDs/gcc/static-compat/gdc_phobos_path.patch
Martchus 5411a9d1fd Update static libraries
* Use an older glibc so resulting binaries can run
  on older systems (without having to link statically
  against glibc)
* Call packages static-compat-* to make it clear that
  these packages are intended for compatibility with
  older distributions
* Add further libraries to get static-compat-qt6-base
  and some other static-compat-qt6-* packages building
2022-04-28 22:43:29 +02:00

15 lines
414 B
Diff

diff -Naur a/gcc/d/d-incpath.cc b/gcc/d/d-incpath.cc
--- a/gcc/d/d-incpath.cc 2019-01-01 13:31:55.000000000 +0100
+++ b/gcc/d/d-incpath.cc 2019-06-28 08:32:00.326241502 +0200
@@ -140,7 +140,7 @@
path = xstrdup (p->fname);
/* Add D-specific suffix. */
- path = concat (path, "/d", NULL);
+ path = concat (path, "/dlang/gdc", NULL);
/* Ignore duplicate entries. */
bool found = false;