PKGBUILDs/qt6-base/mingw-w64/0002-Fix-finding-D-Bus.patch
Martchus 5411a9d1fd Update static libraries
* Use an older glibc so resulting binaries can run
  on older systems (without having to link statically
  against glibc)
* Call packages static-compat-* to make it clear that
  these packages are intended for compatibility with
  older distributions
* Add further libraries to get static-compat-qt6-base
  and some other static-compat-qt6-* packages building
2022-04-28 22:43:29 +02:00

25 lines
873 B
Diff

From 0ee959c716f76b22e32bbcd74d4d3c27c45054eb Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Wed, 7 Oct 2020 12:13:37 +0200
Subject: [PATCH 02/11] Fix finding D-Bus
Change-Id: Ie21eb9cbc6b1b5d9c8b34eea46f54718e5926986
---
cmake/FindWrapDBus1.cmake | 3 +++
1 file changed, 3 insertions(+)
diff --git a/cmake/FindWrapDBus1.cmake b/cmake/FindWrapDBus1.cmake
index e227d224e0..bdbcab9eb3 100644
--- a/cmake/FindWrapDBus1.cmake
+++ b/cmake/FindWrapDBus1.cmake
@@ -45,3 +45,6 @@ include(FindPackageHandleStandardArgs)
find_package_handle_standard_args(WrapDBus1 REQUIRED_VARS
DBus1_LIBRARY DBus1_INCLUDE_DIR WrapDBus1_FOUND
VERSION_VAR DBus1_VERSION)
+if(TARGET dbus-1)
+ set_property(TARGET dbus-1 PROPERTY IMPORTED_IMPLIB ${DBus1_LIBRARY})
+endif()
--
2.36.0