PKGBUILDs/qt5-winextras/mingw-w64/0001-Fix-condition-for-_WIN32_IE-SHCreateItemFromParsingN.patch
Martchus c9819b9c7c Update mingw-w64-qt5-* to 5.8.0
* Adapt hacks to new config system
* Use distinct mkspec mingw-w64-g++ rather than
  patching the existing win32-g++
* Testing QML and ANGLE is on TODO list
  because it hasn't been tested since quite a time
2017-02-09 16:10:06 +01:00

26 lines
801 B
Diff

From f00d75eaf8c61607543563d50630bf8084bf936d Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 9 Feb 2017 01:07:46 +0100
Subject: [PATCH] Fix condition for _WIN32_IE/SHCreateItemFromParsingName
---
src/winextras/qwinjumplist.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/winextras/qwinjumplist.cpp b/src/winextras/qwinjumplist.cpp
index 9274cc5..962481e 100644
--- a/src/winextras/qwinjumplist.cpp
+++ b/src/winextras/qwinjumplist.cpp
@@ -41,7 +41,7 @@
#include <QtCore/QtGlobal>
#ifdef Q_CC_MINGW // MinGW: Enable SHCreateItemFromParsingName()
-# if defined(_WIN32_IE) && _WIN32_IE << 0x0700 // _WIN32_IE_IE70
+# if defined(_WIN32_IE) && _WIN32_IE < 0x0700 // _WIN32_IE_IE70
# undef _WIN32_IE
# endif
# ifndef _WIN32_IE
--
2.11.1