PKGBUILDs/qt5-webkit/mingw-w64/qt5-qtwebkit-mfence-mingw.patch
Martchus f7924a9daa Fix a few mistakes in mingw-w64-qt5-* packages
- Some modules contain executables to run on the host
  and hence mustn't have the architecture 'any'.
- Host tools in modules are stripped now
- Missing mfence in Atomic.h (header of WTF) is fixed
  in a more appropriate way
2016-06-22 22:33:30 +02:00

12 lines
328 B
Diff

--- Source/WTF/wtf/Atomics.h.orig 2016-06-19 14:44:16.829726076 +0200
+++ Source/WTF/wtf/Atomics.h 2016-06-19 14:49:05.596958910 +0200
@@ -68,6 +68,8 @@
#elif !COMPILER(GCC)
extern "C" void _ReadWriteBarrier(void);
#pragma intrinsic(_ReadWriteBarrier)
+#else
+#include <intrin.h>
#endif
#include <windows.h>
#elif OS(QNX)