PKGBUILDs/qt5-base/mingw-w64-static/0023-Use-correct-pkg-config-static-flag.patch
Martchus defbb48223 Change work around for using static Qt 5 with CMake
* Make it possible to use shared and static Qt build (installed
  in the same prefix) at the same time in a project.
* This allows compiling shared and static libraries depending on
  Qt in one step.
* Static CMake modules are prefixed with 'Static', eg. 'StaticQt5Core'
  and provide importet targets as eg. 'Qt5::static::Core'.
2016-11-02 21:25:48 +01:00

29 lines
1018 B
Diff

From dd59260d2a1644664c1e1c7cb74abe5574b4989b Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 18 Sep 2016 18:50:21 +0200
Subject: [PATCH 23/25] Use correct pkg-config --static flag
---
configure | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/configure b/configure
index b4c75c6..eea15f0 100755
--- a/configure
+++ b/configure
@@ -4153,6 +4153,11 @@ if [ -z "$PKG_CONFIG" ]; then
# See if PKG_CONFIG is set in the mkspec:
PKG_CONFIG="`"$CFG_QMAKE_PATH" -qtconf "$QTCONFFILE" -E -nocache -spec "$XQMAKESPEC" "CONFIG=" $DEV_NULL 2>&1 | sed -n -e 's,^PKG_CONFIG = \(.*\),\1,p'`"
[ -n "$PKG_CONFIG" ] && [ "$OPT_VERBOSE" = "yes" ] && echo "Found pkg-config from mkspec: $PKG_CONFIG"
+
+ if [ "$CFG_SHARED" = "no" ] ; then
+ PKG_CONFIG="$PKG_CONFIG --static"
+ [ "$OPT_VERBOSE" = "yes" ] && echo "Using '$PKG_CONFIG' because we're doing a static build"
+ fi
fi
if [ -z "$PKG_CONFIG" ]; then
PKG_CONFIG=`"$WHICH" pkg-config 2>/dev/null`
--
2.10.1