PKGBUILDs/qt5-base/mingw-w64-static/0018-Use-system-zlib-for-build-tools.patch
Martchus defbb48223 Change work around for using static Qt 5 with CMake
* Make it possible to use shared and static Qt build (installed
  in the same prefix) at the same time in a project.
* This allows compiling shared and static libraries depending on
  Qt in one step.
* Static CMake modules are prefixed with 'Static', eg. 'StaticQt5Core'
  and provide importet targets as eg. 'Qt5::static::Core'.
2016-11-02 21:25:48 +01:00

26 lines
726 B
Diff

From 2e7791965e771e6d4a544a6b81e86cba8ad6b181 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 18 Sep 2016 18:04:42 +0200
Subject: [PATCH 18/25] Use system zlib for build tools
---
src/tools/bootstrap/bootstrap.pro | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/tools/bootstrap/bootstrap.pro b/src/tools/bootstrap/bootstrap.pro
index a431052..b97ff0a 100644
--- a/src/tools/bootstrap/bootstrap.pro
+++ b/src/tools/bootstrap/bootstrap.pro
@@ -134,7 +134,7 @@ macx {
../../corelib/io/qstandardpaths_win.cpp
}
-contains(QT_CONFIG, zlib)|cross_compile {
+contains(QT_CONFIG, zlib) {
include(../../3rdparty/zlib.pri)
} else {
CONFIG += no_core_dep
--
2.10.1