PKGBUILDs/qt5-base/mingw-w64-static/0016-Build-dynamic-host-libraries.patch
Martchus defbb48223 Change work around for using static Qt 5 with CMake
* Make it possible to use shared and static Qt build (installed
  in the same prefix) at the same time in a project.
* This allows compiling shared and static libraries depending on
  Qt in one step.
* Static CMake modules are prefixed with 'Static', eg. 'StaticQt5Core'
  and provide importet targets as eg. 'Qt5::static::Core'.
2016-11-02 21:25:48 +01:00

39 lines
1.3 KiB
Diff

From 61bdeeb1fd3b4eabc204fd65dd9049ddaeb5583f Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 18 Sep 2016 14:27:28 +0200
Subject: [PATCH 16/25] Build dynamic host libraries
For better accordance with Arch Linux packaging
standards
---
mkspecs/features/qt_module.prf | 2 +-
src/tools/bootstrap-dbus/bootstrap-dbus.pro | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/mkspecs/features/qt_module.prf b/mkspecs/features/qt_module.prf
index 5bd5101..30a325b 100644
--- a/mkspecs/features/qt_module.prf
+++ b/mkspecs/features/qt_module.prf
@@ -25,7 +25,7 @@ isEmpty(VERSION): error("Module does not define version.")
# Compile as shared/DLL or static according to the option given to configure
# unless overridden. Host builds are always static
-host_build|staticlib: CONFIG += static
+staticlib: CONFIG += static
host_build {
QT -= gui # no host module will ever use gui
diff --git a/src/tools/bootstrap-dbus/bootstrap-dbus.pro b/src/tools/bootstrap-dbus/bootstrap-dbus.pro
index c3ed27d..30d2114 100644
--- a/src/tools/bootstrap-dbus/bootstrap-dbus.pro
+++ b/src/tools/bootstrap-dbus/bootstrap-dbus.pro
@@ -27,4 +27,4 @@ SOURCES = \
load(qt_module)
lib.CONFIG = dummy_install
-INSTALLS = lib
+INSTALLS += lib
--
2.10.1