PKGBUILDs/qt5-base/mingw-w64-static/0003-Don-t-set-QT_NO_SYSTEMSEMAPHORE-for-Windows.patch
Martchus defbb48223 Change work around for using static Qt 5 with CMake
* Make it possible to use shared and static Qt build (installed
  in the same prefix) at the same time in a project.
* This allows compiling shared and static libraries depending on
  Qt in one step.
* Static CMake modules are prefixed with 'Static', eg. 'StaticQt5Core'
  and provide importet targets as eg. 'Qt5::static::Core'.
2016-11-02 21:25:48 +01:00

26 lines
799 B
Diff

From 93f3b6c5d93a539bcebd3087b6209a9dd81104fd Mon Sep 17 00:00:00 2001
From: Mark Brand <mabrand@mabrand.nl>
Date: Thu, 6 Aug 2015 13:24:56 +0200
Subject: [PATCH 03/25] Don't set QT_NO_SYSTEMSEMAPHORE for Windows
---
configure | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure b/configure
index 43b55f0..de2c3ec 100755
--- a/configure
+++ b/configure
@@ -4656,7 +4656,7 @@ fi
[ "$XPLATFORM_ANDROID" = "yes" ] && QMakeVar add styles "android"
# check IPC support
-if ! compileTest unix/ipc_sysv "ipc_sysv" ; then
+if [ "$XPLATFORM_MINGW" = "no" ] && ! compileTest unix/ipc_sysv "ipc_sysv" ; then
# SYSV IPC is not supported - check POSIX IPC
if compileTest unix/ipc_posix "ipc_posix" ; then
QCONFIG_FLAGS="$QCONFIG_FLAGS QT_POSIX_IPC"
--
2.10.1