PKGBUILDs/qt6-base/mingw-w64-static/0005-Fix-libjpeg-workaround-for-conflict-with-rpcndr.h.patch
Martchus 1c6dcbd4ed Update Qt 6 packages to beta3, add mingw-w64-qt6-*-static packages
* Add certain variables to find Qt's dependencies to the CMake
  toolchain file because these variables would otherwise needed to
  be set every time Qt 6 is used
* Add a static variant
    * Not fully tested yet
    * Further repos besides base and svg will be added later
2020-11-06 23:40:34 +01:00

38 lines
1.3 KiB
Diff

From 0f92aeca18858e11ddaa25b7cdad7d89303052ea Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Mon, 2 Nov 2020 13:47:45 +0100
Subject: [PATCH 5/5] Fix libjpeg workaround for conflict with rpcndr.h
Otherwise it won't compile against mingw-w64-libjpeg-turbo. This version of
libjpeg seems to take care of the conflict already as long as jconfig.h is
included before jmorecfg.h.
Change-Id: I011b7735485689c9797cffe2646c8c3d15d0645e
---
src/plugins/imageformats/jpeg/qjpeghandler.cpp | 8 +-------
1 file changed, 1 insertion(+), 7 deletions(-)
diff --git a/src/plugins/imageformats/jpeg/qjpeghandler.cpp b/src/plugins/imageformats/jpeg/qjpeghandler.cpp
index 29bf5ab589..dc336f156a 100644
--- a/src/plugins/imageformats/jpeg/qjpeghandler.cpp
+++ b/src/plugins/imageformats/jpeg/qjpeghandler.cpp
@@ -61,14 +61,8 @@
// including jpeglib.h seems to be a little messy
extern "C" {
-// jpeglib.h->jmorecfg.h tries to typedef int boolean; but this conflicts with
-// some Windows headers that may or may not have been included
-#ifdef HAVE_BOOLEAN
-# undef HAVE_BOOLEAN
-#endif
-#define boolean jboolean
-
#define XMD_H // shut JPEGlib up
+#include <jconfig.h> // ensure jconfig.h is included before jmorecfg.h
#include <jpeglib.h>
#ifdef const
# undef const // remove crazy C hackery in jconfig.h
--
2.29.2